OTAVA® Encore (portal.otava.com) Outage - 4/22/2026

Incident Report for Otava Status Page

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 12:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 11:43 EDT

Investigating

Service Impacting: Yes – Encore services may be unavailable until further notice.

Description: OTAVA engineers are currently investigating an unexpected outage impacting Encore (portal.otava.com). Related services may not be available at this time.

If you have any questions or concerns regarding this incident, please contact us by logging into https://support.otava.com or calling 877-740-5028, option 3.
Posted Apr 22, 2026 - 09:59 EDT
This incident affected: Client Services (Encore (portal.otava.com)).