Ann Arbor (AA2) Utility Power Interruption - 10/3/2024
Incident Report for Otava Status Page
Resolved
Utility power was successfully restored at 10:51 AM. All systems are operating normally. DTE determined that the interruption was caused by Animal/bird-damaged DTE equipment.
Thank you,
Posted Oct 03, 2024 - 11:36 EDT
Investigating
Start Time: 10/3/24 - 8:00 AM ET

Service Impacting: No - Due to the redundant nature of the design, no impact is expected

The Ann Arbor (AA2) data center has encountered a utility disruption. All systems successfully transferred to generator power and OTAVA® engineers are onsite and will continue to monitor the situation. Estimated restoration is 11:25am ET.

If you have any questions or concerns regarding this maintenance please contact us by logging into https://support.otava.com or calling 877-740-5028, option 3.
Posted Oct 03, 2024 - 09:09 EDT
This incident affected: AA2 - Ann Arbor, MI (Colocation Services (Power, Cooling)).