Mid-Michigan (MM1) - Internet Connectivity Degradation - 9/7/2026

Incident Report for Otava Status Page

Monitoring

Update:
Our Networking Team has successfully implemented a fix to address the internet connectivity degradation affecting the Mid-Michigan (MM1) shared cloud environment.

We are currently monitoring the environment to ensure the fix holds and that all services remain stable.
Posted Sep 07, 2026 - 11:37 EDT

Identified

Update: Our Networking Team has identified the root cause of the internet connectivity degradation affecting the Mid-Michigan (MM1) shared cloud environment.

We are currently implementing a fix to restore normal network performance and stabilize routing. Tenants may begin to see improvements in latency and connection quality as these mitigations take effect.

We will continue to monitor the network traffic closely and will provide the next update within 30 minutes.
Posted Sep 07, 2026 - 11:15 EDT

Investigating

Service Impacting: Yes

Description:
We are currently investigating reports of intermittent internet connectivity degradation affecting customers hosted in our Mid-Michigan (MM1) shared cloud environment.

Impact:
During this time, tenants may experience increased network latency, packet loss, or brief connection resets when accessing services, virtual machines, and applications hosted in the (MM1) shared cloud.

For questions or assistance, don't hesitate to get in touch with OTAVA Support at support@otava.com or (877) 740-5028, Option 3.
Posted Sep 07, 2026 - 10:51 EDT
This incident affects: MM1 - Flint, MI (Mid-Michigan) (OTAVA Shared Cloud).