Ann Arbor (AA2) OTAVA® Data Center Networking Infrastructure Degradation

Incident Report for Otava Status Page

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 16:19 EDT

Identified

Service Impacting: Yes

Description:
OTAVA engineers are investigating degraded performance affecting the Data Center Networking Infrastructure in Ann Arbor (AA2). Customers may experience intermittent connectivity or increased latency while the investigation is underway.

Additional updates will be provided as more information becomes available.

For questions or assistance, please contact OTAVA Support at support@otava.com or (877) 740-5028, Option 3.
Posted Jul 15, 2026 - 11:16 EDT
This incident affects: AA2 - Ann Arbor, MI (Data Center Networking Infrastructure).