OTAVA®Phone System Outage
Incident Report for Otava Status Page
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 00:13 EDT
Identified
We are currently experiencing an issue affecting our phone system. Our team is actively collaborating with the vendor to resolve the issue as quickly as possible. We are closely monitoring the situation and will provide timely updates as more information becomes available.

We sincerely apologize for any inconvenience this may cause and appreciate your understanding and patience during this time.

If you have any questions or concerns regarding this please contact us by logging into
https://support.otava.com or calling 877-740-5028, option 3.
Posted Sep 10, 2024 - 21:52 EDT
This incident affected: Client Services (OTAVA Support Phone System).