Encore (portal.otava.com) Service Unavailable - 8/8/25

Incident Report for Otava Status Page

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 15:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2025 - 09:12 EDT

Investigating

OTAVA® engineers are currently investigating a service degradation with Encore (portal.otava.com) affecting client access. Updates will be posted as they become available.
Posted Aug 08, 2025 - 08:55 EDT
This incident affected: Client Services (Encore (portal.otava.com)).