Denver (DEN1) DRaaS powered by Veeam (OCC) Service Degraded - 6/13/25

Incident Report for Otava Status Page

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 21:03 EDT

Investigating

OTAVA® engineers are investigating a possible service degradation with DEN1 OCC. Some clients could be experiencing failed jobs and restores may be unavailable.
Posted Jun 13, 2025 - 16:50 EDT
This incident affected: DEN1 - Denver, CO (DRaaS powered by Veeam (OCC)).