Mid-Michigan(MM1) - Internet Connectivity Degradation - 6/3/2026

Incident Report for Otava Status Page

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 08:52 EDT

Monitoring

Engineers are currently monitoring network traffic for stability.
Posted Jun 03, 2026 - 17:34 EDT

Investigating

We are currently investigating this issue.
Posted Jun 03, 2026 - 17:29 EDT
This incident affected: MM1 - Flint, MI (Mid-Michigan) (OTAVA Shared Cloud).