Utility power has been restored at 1:10 PM. Thank you,
Posted Dec 03, 2024 - 13:10 EST
Investigating
Start Time: 12/3/24 - 11:16 AM ET End Time: Estimated 2:45 PM ET Type: Utility Disruption Service Impacting: No - Due to the redundant nature of the design, no impact is expected. Description: At 11:16 AM we experienced a utility power interruption at the AA2 data center. Power was successfully transferred to generator power. DTE has an estimated restoration time of 2:45 PM. We have staff onsite monitoring the situation. We will provide updates until utility power has been restored. If you have any questions or concerns regarding this maintenance, please contact us by logging into https://support.otava.com or calling 877-740-5028, option 3. AA2 - Ann Arbor, MI - Building Systems
Posted Dec 03, 2024 - 12:45 EST
This incident affected: AA2 - Ann Arbor, MI (Colocation Services (Power, Cooling)).