OTAVA® MM Data Center on backup Generator power.
Incident Report for Otava Status Page
Resolved
Utility Power has been restored and all systems are operating as expected.
Posted Mar 20, 2023 - 13:55 EDT
Investigating
Utility power failed at 11:19 AM at the OTAVA® Flint data center. The Flint data center is currently running on backup generator power. No customers were affected by this outage. Consumers Energy has estimated a restoration time of 4:30 PM. Personnel is currently onsite and monitoring the situation. We will continue to provide updates here until Utility power is restored.

Thank you,
Data Center Operation Team
Posted Mar 20, 2023 - 12:08 EDT
This incident affected: MM1 - Flint, MI (Mid-Michigan) (Colocation Services (Power, Cooling)).